====== Copying or Moving a Survey Project ====== This chapter describes how to duplicate a survey project (i.e., the questionnaire incl. the list of questions). * This can be useful, for example, if you want to refer back to the old list of questions in a follow-up study. * This way, you can also move a survey project from one server to another server, for example from the standard server %%www.soscisurvey.de%% to the Pro server or to the local server of a university. **Recommendation:** Do __not__ copy projects if you merely want to conduct the survey in multiple languages, with different target groups, or with different stimuli. There are considerably more efficient functions for this: * [[:en:create:multilang|Multilingual Surveys]] * Marking the link for different target groups ([[:en:survey:url#marking_a_url_r|URL to the Questionnaire]]) * Multiple questionnaires in one project ([[:en:create:questionnaire|Compose Questionnaire]]) * [[:en:create:placeholders|Placeholders]] * [[:en:create:randomization|Randomization]] * [[:en:general:authorization|Shared Access to Survey Projects]] ===== Duplicate Project ===== A survey is made up of different components: * Questionnaire incl. list of questions, text elements, labels and layouts * Files (e.g. uploaded images) * Collected data * Addresses for [[:en:survey:mailing|Mailings]], [[:en:create:databank]] When a project is copied, only the questionnaires and files (up to 1 MB) will be copied over. The collected data and other dynamic content (list of contacts incl. participation status, a content database) will not be copied or must be copied separately if required. **Note:** Please __do not__ try to log into different projects in different browser tabs. You can only be logged into one survey project in a browser at a time. If you want to work in different survey projects at the same time, use the "private browser window" function in your browser (you can log in separately in the private and normal browser windows) or use different browsers. To copy a questionnaire (list of questions and questionnaires), proceed as follows. - Export the questionnaire as XML file * either under **Survey Project** -> **Project Settings** -> tab //Import/Export// -> //Export questionnaire// -> //Survey project (XML file)// {{::button.download.png?nolink|Button: Download project as archive file}} * or in **My Account** -> **Projects** with the download symbol {{::button.download.png?nolink|Button: Download project as archive file}} (also possible for archived survey projects). - You will receive the XML file as a download: save this onto your computer in case your browser does not automatically store them in the download directory. - Create a new project in **My Account**. * If you use the cloud service of SoSci Survey, you can choose between the standard server ''%%www.soscisurvey.de%%'' and the Pro server ''%%s2survey.net%%'' in the first step. * If you would like to collect [[:en:general:dsgvo|personal data]], choose the Pro server. - Import the previously saved XML file in a new project * either SoSci Survey already offers to import a file when creating the project (//upload survey project//) * or under **Survey Project** -> **Project Settings** -> tab //Import/Export// -> //Import project or questions// -> select the file and confirm with the button on the right. - In the **Project Settings**, adjust the //name of the project// so that you do not confuse the survey projects in the user account. Confusion always leads to data loss! **Important:** Before importing, check that you are logged into the new (empty) survey project. Be wary if you have to select the box "Okay, delete all previously collected survey data". **Tip:** Downloading the XML file __does not__ serve as documentation of the questionnaire. Advice regarding this can be found in the chapter [[:en:results:documentation|Tips on Documenting in Research Reports]] **Tip:** If you only want to copy a layout or a few questions from one survey into another then you can download these elements as XML files and import these into another project; just like you would with a complete survey. ===== Copy Collected Data ===== In rare cases it is useful to copy not only the questionnaire but also the collected data (data set). To achieve this, please proceed as follows: - Copy the questionnaire as explained above. * Make sure you can distinguish the survey projects. * For this it is useful to enter a different //Project name// in the **project settings** in each case. - Switch to the original project in which the collected data are available. - Set which records are to be copied under **Collected data** -> **Filter Criteria for Valid Cases**. * When copying, only the data is copied, not the metadata -- specifically not the information about which items were queried but not answered. Therefore, the variables MISSING, MISSREL, and TIME_RSI ([[:en:results:variables]]) cannot be used to filter cases after importing the data in a new survey project. * Therefore, you should copy only those cases that you intend to use after import. - Under **Collected Data** -> **Download Data**, click //Reset Download Settings//. This is especially necessary if you have customized the settings for the CSV format. - Download the data set under **Collected data** -> **Download data** in the //CSV (Excel/OpenOffice)// tab as a CSV file. Your browser either offers the file for download or saves it directly to the download directory of your hard drive. - Switch to the project copy. To be on the safe side, check again under **Collected data** -> **View data set** that you are really in the right survey project. No data should be displayed there. - In the **Control** on the left, select **Collected data** -> **Import data**. Now select there as //File with data (CSV)// the CSV file that you have just downloaded in the other survey project and confirm with //OK//.. - Now check in **Collected data** -> **View data** to see if the import worked.